読者です 読者をやめる 読者になる 読者になる

uoz 作業日記

様々な作業の記録を共有するブログです。

Bundle install で "Please remove gem 'meta_search' and try again."

Rails使っててbundle installで

Your Gemfile requires gems that depend on each other, creating an infinite loop. Please remove gem 'meta_search' and try again.

と怒られた場合


俺の場合GemfileのActive Adminのバージョン指定だった。

古いActive Adminはmeta searcに依存しているらしい。

参考
Please remove gem 'meta_search' and try again. · Issue #3926 · activeadmin/activeadmin · GitHub

Gemfileにこう書けばOK

gem 'activeadmin', '~> 1.0.0.pre1'

どうせこういう細かいことは載っていないが、Railsについて何がなんだかわからない状態の人は本を買おう